Logitech Quickcam messenger plus en GNU/Linux

Escrito por Multi, el 24 de octubre de 2007
votarmeneala

Si en vuestro día cometisteis el error (como yo hice) de comprar esta webcam que no esta soportada en Linux, seguramente aprendisteis que solo hay que comprar hardware compatible para GNU/Linux. De este modo, además de asegurarnos que todo funcionara a la primera sin problemas, también estaremos apoyando a las empresas que producen hardware compatible con nuestro sistema operativo.

Pero, en nuestro caso, aun hemos tenido suerte, y alguien ha programado drivers para nuestra webcam, así que vamos a instalarlos, y por fin podremos utilizarla en el aMsn, kopete…

Antes de nada, tenéis que instalar los headers de vuestro kernel y el paquete build-essential. Para ello, utilizad el gestor de paquetes de vuestra distro. En cualquier distribución basada en Debian (Ubuntu, Knoppix, Linspire…) podéis hacerlo de esta manera:

Escribid la siguiente orden en un terminal o consola para averiguar la versión de vuestro kernel.

uname -r

Ahora que ya sabemos que versión tenemos (fijaros bien, porque si utilizáis la versión del kernel 2.6.24 tendréis que aplicar un parche antes de instalar el driver), instalamos (como root o super usuario) los headers y el paquete build-essential de este modo:

aptitude install build-essential linux-headers-[aquí va la versión del kernel (sin los corchetes)]

Una vez hecho esto pasamos a descargar e instalar el driver. Lo podemos descargar de aquí. Esta es la ultima versión actualmente, con el tiempo puede que la actualicen, podéis encontrar siempre la ultima versión para descargar aquí.

Ahora descomprimimos el archivo que nos hemos descargado. Si como he dicho antes tenéis la version del kernel 2.6.24 haced esto:

1 – Descargar el parche. (Botón derecho guardar enlace como…)

2 – Aseguraros de guardar el parche en el mismo directorio donde habeis descomprimido el driver (nunca dentro del directorio qc-usb-messenger-1.7)

3 – Aplicar el parche de este modo:

patch -p0 < qc-usb-messenger-1.7-2.6.24.patch

Ya esta, podemos instalar ya en driver de la webcam. Abrimos un terminal, nos situamos dentro del directorio que habremos creado. Por ejemplo, en mi caso, que lo he descomprimido en el escritorio seria así:

cd /home/GpoNsU/Desktop/qc-usb-messenger-1.7/

Una vez en el directorio correspondiente, solo tenemos que ejecutar la siguiente orden en consola:

./quickcam.sh LINUX_DIR=/usr/src/linux-headers-[aquí va la versión del kernel (sin los corchetes)]

Y ya esta, solo hay que seguir las instrucciones del instalador, que se resumen en darle al intro varias veces, e introducir nuestra contraseña de root o super usuario cuando nos lo pida, así que atentos.

Ahora para comprobar que todo a ido bien, podéis lanzar kopete, amsn o cualquier programa que soporte webcam para corroborarlo.

Finalmente, para que el modulo de la webcam se cargue al iniciar el ordenador, tendréis que hacer lo siguiente (como root):

nano /etc/modules

Se abrira un editor de texto, añadid al final del archivo “quickcam” (sin comillas), guardad (ctrl + o) y salid (ctrl + x).

Y ya esta, nuestra webcam funcionando perfectamente. Espero que os haya sido útil, y cualquier duda o sugerencia, espero que la comentéis.

Un Saludo.

48 Comentarios en “Logitech Quickcam messenger plus en GNU/Linux”

  1. Edugl dice:

    Muchas gracias por este howto, me ha funcionado perfectamente y sin ningun problema. Usado en Ubuntu Gutsy Gibbon 7.10 con camara Logitech (el modelo exacto no lo se) pero funciona ya!!! :)

  2. KLap dice:

    Tenemos a un jugon del mundo linux en FacilWare jajjaja, me alegro que te haya funcionado. Cualquier cosa ya sabes, y si tienes sugerencias sobre mas HowTo o cualquier tipo de guia truco etc, no dudes en decirlo!! Vuestros deseos son ordenes :p

  3. candido dice:

    sigo todos esos pasos pero no me deja poner la webcam, ni el amsn ni ningún programa. no me da ningun error ni nada, sigo los pasos e introduzco las contraseñas pero no me funciona, xq puede ser?

  4. GpoNsU dice:

    Utilizas Ubuntu verdad?
    Yo lo probé a hacer en Ubuntu hace un tiempo y me pasaba que no me aceptaba la contraseña, fíjate, imagino que te ocurrirá lo mismo. No se si sera por el tema de que Ubuntu utiliza sudo y tal..
    La solución que yo encontré fue lanzar la instalación ya como root (aunque no lo recomiendan.. pero me funciono en este caso)

    sudo ./quickcam.sh LINUX_DIR=/usr/src/linux-headers-[aquí va la versión del kernel (sin los corchetes)]

    Intentalo asi, espero que te funcione.

    Un saludo.

  5. caballe dice:

    a mi me funcione pero va muy muy lenta en amsn
    Como se podria arreglar??

  6. GpoNsU dice:

    ummm pues no podría darte una solución exacta, ya que tu problema puede ser causado por muchos factores:

    El driver: Yo utilizo ese driver y me funciona bien, lo normal para mi conexión a internet creo.

    Conexión: Puede que sea problema de tu conexión, saturación en la red…

    Programa: Puedes probar con otros programas, como por ejemplo kopete, para confirmar que la lentitud no es causada por amsn.

    Hardware: Limitación de la webcam, posible avería…
    ….

    Como ves no es fácil encontrar cual puede ser el problema. Mi recomendación es que vayas descartando uno a uno hasta encontrar que puede estar causando esto, y entonces, seguro que lo solucionaras!

    Un saludo.

  7. Nemesis dice:

    me ha funcionado despues de haber hecho mil intentos con otrso tutoriales pero cuando guardo los cambios y reinicio la maquina ya no me detecta nada de webcam estoy utilizando linux mint 4.0 alguna idea.

  8. GpoNsU dice:

    has añadido a /etc/modules el modulo quickcam? Si no es así haz lo. Si aun así no te carga el modulo al inicio, puedes hacerlo manualmente:

    sudo modprobe quickcam

    Saludos.

  9. Nemesis dice:

    pues lo he intentado; he hecho lo que me dices sudo modprobe quickcam y cada vez que reinicio la maquina pues nada que no reconoce la dichosa camarita me aparece la dichosa frase “could not conect to video device (/dev/video0) please check connection y si he añadido a /etc/modules el modulo quickcam. pero parece que estoy frito es por esto que no me he cambiado del todo a linux estas dichosas camaritas web y sigo padeciendo con windows creo que lo mejor sera dejar en paz la camarita.

    algun plan para solucionar esto? no soy programador n nada solo un usuario promedio que ya no soporta window$ a y gracias por tu tutorial insisto es la primera vez que me funciona la webcam pero tengo que reinstalar todo para que me funcione cada vez que reinicio la maquina disculpa la molestis

  10. ttorrentte dice:

    Tio, eres un pasote, lo había intentado de mil maneras, siguiendo tropemil manuales y nada, pero con esto a la primera. Tengo muchos cortes al usar el amsn, pero es más bien porque mi máquina es un cagarro, ya que con el msn en windows también va media chunga. Muchas gracias.

  11. GpoNsU dice:

    Me alegro que te haya funcionado ttorrente de verdad. En cambio a nemesis se le esta resistiendo.

    Lo que puede estar pasando es que linux mint 4.0 gestione de manera distinta el dispositivo que Debian y Ubuntu.

    Mira alguno de estos enlaces, pues parece que tienen el mismo problema que tu, haber si puedes solucionarlo.

    Un saludo y suerte.

  12. Miquel dice:

    Gracias, conseguí instalar la cámara pero el ordenador se bloquea en muy poco tiempo. A que puede ser debido?

  13. GpoNsU dice:

    Que distribución utilizas? Tienes compiz fusion activado? Drivers gráficos? Tarjeta? …

    Imagino que será un problema gráfico, pero necesito mas datos XD

    Un saludo.

  14. Miquel dice:

    Gracias por haber contestado tan rápido. Resulta que funciona bien. Siii! Con aMSN funciona es con Ekiga que se bloquea. De momento me doy por satisfecho. Ahora tan solo me falta que funcione el sonido con aMSN. No escucho los sonidos del programa, ni puedo hablar con otras personas a trabes de aMSN.
    Uso la distro Ubuntu Gutsy Gibbon. Tengo compiz fusion activado, funcionando bien. Gutsy Gibbon. La gráfica una GeForce 7300 LE y el drivers 100.14.19, …me parece.
    En cuanto al sonido todo me funciona bien menos en aMSN, tal vez falte algún componente para conectar el programa con el sonido del equipo, no se. Los “Acontecimientos sonoros”, “Música y video”, “Conferencias de audio” de la pestaña “Dispositivos están en “Detecta automáticamente”, la utilidad de “Captura el sonido” esta en “Prueba el sonido”, En el apartado de “Pistas del mezclador por defecto” tiene el dispositivo “HDA ATI SB (Alsa mixer).

    Gracias solo por haber leido hasta aquí. :)

  15. Miquel dice:

    Se me olvido decir que cuando intento enviar sonido a trabes de aMSN el programa me dice que no a detectado ningún dispositivo de sonido. En el dispositivo para probar el video y audio en aMSN, en Reproduce el archivo de prueba, se escucha, en dispositivo de salida esta en por defecto, y en el dispositivo mezclador:hw:0.

    Si se os ocurre algo…

    gracias

  16. Miquel dice:

    He encontrado la solución en este enlace.

    http://foros.ubuntu-cl.org/viewtopic.php?p=17632&sid=f1b003f759d573f05ec136c5c5777ddc

    Resumiendo: instalado el paquete que te permite ejecutar el comando play y con la opcion “Usar un comando o programa distinto” “play $sound en Cuenta–>Preferencias–>Otras–>Servidor de Sonido que es la que venia por defecto.

    Fins a la propera

  17. Miquel dice:

    Me he precipitado. Si que me ha funcionado pero solo en el dispositivo de prueba de aMSN y ha dejado de funcionar. En fin, continuaré buscando.

    Gracias

  18. GpoNsU dice:

    Hola, para oir los sonidos puedes hacer dos cosas, instalar la librería “libsnack2” y en preferencias seleccionar dicha libreria para el sonido, o mas fácil aun, y es lo que yo utilizo, que es cambiar el comando “play $sound” por “aplay $sound”. A mi me funciona perfecto así.

    Luego el tema de enviar sonidos con el amsn, es un problema que no he podido solucionar todavía. El micro integrado en la webcam se que me funciona perfectamente, ya que he grabado mi voz para algunos vídeo tutoriales, el problema viene en amsn, que no consigo que me reconozca el dispositivo de sonido como “camera”.

    Si consigo solucionarlo no dudes que te lo haré saber.

    Un saludo y perdona por no contestarte antes, pero estoy en plenos exámenes y ya sabes XD

  19. yooooopo dice:

    Hola compa, ese mismo driver habia instalado hace mucho, y tuve al igual q alguien de mas arriba el problema de tener q volver a instalarlo cada vez q iniciaba sesion…
    Lo malo es que ahroa el problema es otro… toda la instalacion marcha bien… hasta que dice… “Right now driver is loaded and should be ready to run.
    Let’s test if user applications can see it, starting with qcset.”
    Entonces lo intenta probar… y me dice: “[!] qcset did not found the QuickCam camera” y me recomienda abandonar la instalacion… claro, podria seguir pero se que al final tendre mala la instalacion y no funcionara … :S Que puedo hacer.. que me recomiendas?

  20. yooooopo dice:

    Por cierto, uso ubuntu feisty

  21. yooooopo dice:

    Jajajaja, menuda chorrada… da igual gponsu… le di a seguir con la instalacion y funciono perfectamente.. xD pensar que luego lo que me falto todo este tiempo fue incluir quickcam a /etc/modules jajaja, saludos, buen tuto ;)

  22. GpoNsU dice:

    Suele pasar que muchas veces nos volvemos locos con algo, y simplemente nos falta un pequeño detalle, a mi me esta pasando algo así ahora mismo con otro programa XD

    Me alegro que hayas conseguido que te funcione.

    Un saludo!

  23. Festor dice:

    Te puedes ahorrar muchos pasos haciendo esto:

    aptitude install build-essential linux-headers-`uname -r`

    en vez de esto

    aptitude install build-essential linux-headers-[aquí va la versión del kernel (sin los corchetes)]

  24. c0kit0_2oo7 dice:

    Hombre, tanto como ahorrar muchos pasos… solo te ahorras escribir la versión del kernel :p

  25. caro dice:

    necesito ayuda para instalar mi camara, quickcam fusion.
    tengo una ibook g4 y soy nueva en todo esto. por favor alguien puede ayudarme?

  26. […] gestor de paquetes. Teniendo en cuenta que en esta partición he compilado los drivers de la webcam quickcam express de logitech y de la tarjeta de sonido que viene incorporada a mi placa base no me extraña que se le atragante […]

  27. Gabriel dice:

    necesito ayuda para instalar mi camara,tengo una genius y soy nuevo en todo esto. por favor alguien puede ayudarme? mi versión del kerne es 2.6.22-14-generic

  28. GpoNsU dice:

    Este tutorial esta pensado para la Quickcam Messenger, si nos dices el modelo de tu genius intentaremos ayudarte.

    Un saludo.

  29. GpoNsU dice:

    Hola caro,

    El problema es que yo no tengo tu modelo de Webcam y no puedo probar si funcionan realmente, pero en esta pagina parece ser que hay drivers para tu webcam, pruebalos y nos cuentas.

    Un saludo.

  30. momotombo dice:

    Saludos a todos, estoy migrando a Ubuntu con todas mis maquinas para un ciber cafe, ya sali de muchos problemas que tuve al hacer concexiones a internet y redes, ahora tengo el problema de que no puedo hacer funcionar la camara web de genius ilook 111 que puedo hacer, recuerden que soy muy novato y no quiero darme por vencido con este sistema operativo y no volver a windows y asi ofrecer a la comunidad linux ubuntu
    USo el terminal pero me dice que no tengo muchos privilegios y no se pudo realizar la accion que estoy solicitando y luego me pregunta si soy root, como hago para entrar como root o instalar los benditos programas que me recomiendan los foros

    Gracias espero su ayuda,

  31. GpoNsU dice:

    En Ubuntu no puedes iniciar sesion como root. Para instalar progranas puedes utilizar el gestor grafico de paquetes synaptic o desde consola:

    sudo aptitude install nombreprogramaquequierasinstalar

    En cualquiera de los dos metodos te pedira la contraseña de usuario.

    El comando sudo es el que te permite adquirir permisos de root.

    Un saludo.

  32. fernanperal dice:

    Hola he seguido los pasos pero me sale el siguiente error:

    Make version: GNU Make 3.81
    Linker version: GNU ld (GNU Binutils for Ubuntu) 2.18.0.20080103
    Kernel compiler: gcc version 4.2.3 (Ubuntu 4.2.3-2ubuntu7)
    [!] Kernel compiler and gcc seem to be different versions.
    Instead, they should be the same. If you have many compilers
    installed, you can specify the correct one with command (in bash)
    export CC=kgcc
    before trying to install the driver. Replace kgcc with the command
    required for compiling kernels (kgcc is often used in Red Hat systems).
    WARNING: If you press Enter, I’ll try to continue anyway,
    but this probably will fail. You SHOULD press Ctrl+C now.

    Como puedo hacer para cambiar el compilador??

    Gracias por tu ayuda!

  33. GpoNsU dice:

    Mas que un error es un warning, yo seguiría adelante, no tendría por que pasar nada.

    Para cambiar el compilador, puedes hacer lo que te indica el warning:

    export CC=kgcc

    Por ejemplo, la si quiero poner la version 4.1, seria así (como root):

    export CC=gcc-4.1

    Un saludo.

  34. lanber dice:

    he seguido todos los pasos y funciona bien, gracias.

  35. yaira dice:

    no entendii nadaaaa!!!

  36. KLap dice:

    yaira leetelo bien, solo hay que seguir los pasos!! esta todo muy bien explicado. Si te surge alguna duda puntual, preguntala y GPoNsU te responderá lo antes posible. Saludos!

  37. seis6seis dice:

    Hola a todos,

    Llevo un tiempo intentando instalar esta webcam pero e usado los driver de la version 1.7 y la 1.8(tiene soporte para el kernel 2.6.24 por lo que no insalo parche) en ambos casos pasa lo mismo lo reconoce, pero la imagen sale negra.

    Al probar desde terminal con xawtv -c /dev/video0 veo un error:
    “ioctl: VIDIOCSYNC(int=0): No hay espacio libre en el dispositivo”

    Uso Ubuntu 8.04, con kernel 2.6.24

  38. Jhonnathan G dice:

    Bus 001 Device 004: ID 046d:089d Logitech, Inc.
    Bus 001 Device 002: ID 0458:003a KYE Systems Corp. (Mouse Systems)
    Bus 001 Device 001: ID 0000:0000
    Bus 002 Device 001: ID 0000:0000

    Esto es lo que me dice la consola cuando le pongo el comando lsusb

    ya realice todo lo que dice aqui en esta pagina al pie de la letra que realmente es la unica que me ha dado una luz de esperanza pero aun no funciona la camara… que puedo hacer??? si pudieran ayudarme les agradeceria mucho…

    La referencia de mi camara es Logitech QuickCam Connect E 2500 Series…
    Gracias

  39. Fearless dice:

    El mejor tutorial que he leído en mi vida, gracias resolviste mi duda, eternamente agradecido.
    Gracias

  40. xurde dice:

    veo la camara bien pero no se me escucha cuando hablo con otro k puedo hacer

  41. mireiia dice:

    Alguien tiene los drivers de la camara web: quickcam messenger para windows vista? Esque yo la tengo y con el sistema operativo del vista no me funciona.

    Ayudarme

  42. franosw dice:

    Saludo cordial.Tengo la version de Kernel 2.6.24-22-generic en Ubuntu 8.04 y quiero saber si el parche que comentas se debe instalar en esta version de Kernel, para poder utilizar la webcam E2500 de logitec.Gracias.

  43. GpoNsU dice:

    En Ubuntu 8.04 no es necesario ningún parche, yo instale la webcam sin problemas. Donde tuve problemas fue en la nueva 8.10.

    PD: Comentarte que en distribuciones como openSUSE y Mandriva, es mucho mas fácil instalar esta webcam. En openSUSE te la detecta automáticamente en la instalación y no necesitaras hacer nada para que funcione. Y en mandriva solo tendrás que instalar un paquete desde los repositorios.

    Un saludo.

  44. karmen dice:

    como le hago para conectar una webcam de 1.3 mp si no tengo cd de programacion

  45. alberto dice:

    Hola:
    Alguien me podria ayudar a instalar la quickcam messenger plus en suse 11.1, tengo poca experiencia con linux (1 semana) me pasado buscando como instalarlo mucho tiempo y aun asi no logro resultados… alguien podria explicarme paso a paso sin dejarse nada (soy novato) para instalar esta webcam.
    Muchas gracias.

  46. Ernesto dice:

    tengo un problema porque al tratar de instalar la camara esto es lo que me tira el compilador:

    Next round: let’s see if you have a supported QuickCam.
    Please plug in your USB camera before continuing.
    Press Ctrl+C to quit, Enter to continue —>

    I can find the following probably compatible devices:
    [!] Didn’t find compatible cameras.
    If you got message: “Permission denied”, it means that
    you simply have too old lsusb, and you can ignore this problem.
    In this case you have to be root to use lsusb, but I won’t do that.
    WARNING: If you press Enter, I’ll try to continue anyway,
    but this probably will fail. You SHOULD press Ctrl+C now.
    Press Ctrl+C to quit, Enter to continue —> ^C

    asi que revise que tenía conectado a los puertos USB y resulta que esto es lo que aparece:

    servored@casa:~/Desktop/qc-usb-messenger-1.8$ lsusb
    Bus 001 Device 002: ID 046d:08da Logitech, Inc. QuickCam Messanger
    Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

    Si se fijan la camara es reconocida pero aparece la palabra Messanger en vez de Messenger.

    Será por eso el problema a que el compilador no la detecta? o es otro el problema? habrá una forma de hacerle un upgrade a los controladores del usb o es algo distinto?…..ojalá alguien me pueda ayudar.

    estoy usando Debian Lenny y necesito aprender como instalar esta camara para una parte de mi proyecto final de carrera….

    Gracias.

  47. Marcelo dice:

    Tengo un problema tengo una camara web marca KOLKE (JPEG Web Cam) y no aparece la imagen solo rayas amarillas, estoy como loco creo que me voy a comprar otra AYUDA

  48. nicolas dice:

    ola aleja te amo

Deja un comentario