Solucionar el problema con las dependencias al actualizar Gimp 2.7.5

Escrito por melenas1414, el 15 de febrero de 2012
votarmeneala

gimp

Ayer fui a instalar la última versión de Gimp desde repositorios en Ubuntu 11.10, la versión 2.7.5 y me dio problemas con las dependencias, no os puedo decir cuales porque fueron varias, me pedían la versión 2.31 y tenía la versión 2.30. Buscando información me enteré que en la versión 12.04 de Ubuntu  no daba problemas porque estas dependencias estaban actualizadas, pero yo no quería poner Ubuntu 12.04 todavía, así que seguí buscando y encontré la solución. Después del salto os cuento la solución.

La solución es sencilla, solo debemos añadir un nuevo repositorio a nuestra lista y actualizar, veamos como se hace:

Abres la terminal y escribes lo siguiente:

gksudo gpedit /etc/apt/source.list

Y al final del archivo ponemos lo siguiente:

deb http://ppa.launchpad.net/gnome3-team/gnome3/ubuntu oneiric main

deb http://ppa.launchpad.net/ricotz/testing/ubuntu oneiric main

Lo cerramos y guardamos. Desde la terminal escribimos el siguiente comando:

sudo apt-get update && sudo apt-get upgrade

Listo con esto se nos actualizan las dependencias y así ya podemos instalar gimp 2.7.5:

Si no tenemos agregado el reposito, lo agregamos:

sudo add-apt-repository ppa:matthaeus123/mrw-gimp-svn

Y instalamos gimp

sudo apt-get update && sudo apt-get install gimp

6 Comentarios en “Solucionar el problema con las dependencias al actualizar Gimp 2.7.5”

  1. Live dice:

    segi todos los pasos para resolver el problema de dependecias
    pero no podia abrir la lista, este comando no me funcionaba:

    gksudo gpedit /etc/apt/source.list

    lo soluciones con este otro:

    gksudo gedit /etc/apt/source.list

    • dersuaniae dice:

      Y ese con aqueste:

      gksudo gedit /etc/sources.list

      en plural, pues son varias fuentes, no solo una.

      He de decir, empero, que me sigue dando el mismo problema de dependencias, a saber:

      gimp:
      Depende de: libgimp2.0 pero no va a ser instalado
      Depende de: libgimp2.0 pero no va a ser instalado
      Depende de: libc6 (>=2.15) pero se va a instalar 2.13-20ubuntu5.1
      Depende de: libpoppler-glib8 (>=0.18) but it is not installable

      Nada, ni forzando versión.

      Que si quieres arroz Catalina…

  2. Live dice:

    Segui los pasos y agregue los repositorios en la listas ,
    luego pude instalar Gimp,
    pero le doy a iniciar el programa no se abre,
    me sale una ventana con el siguiente mensaje:

    Gtk+ version too old (micro mismatch)

    GIMP requires GTK+version 2.24.7 or later
    Instlled GTK+version is 2.24.6

    somehow you or your software packager managed
    to intall GIMP with an older GTK+ version

    Please upgrade GTK+ version 2.24.7 or later.

  3. Perolet dice:

    Yo lo he intentado dos veces y dos veces que he tenido que volver a instalar ubuntu.

Deja un comentario